package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^|]+\|){2}(?<field>[^|]+)`)
var str = `message:PSUS7|8897|FISOBPIT10101|OWA|8897|8897|SignOnID|SPT|adding routing key in producer`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}