re = /^(?P<description>.{25}(?=\s{3,})|.{23}|.{25})(?P<city>\S.{12})((?P<region1> (A[KLRZ]|C[AOT]|D[CE]|FL|GA|HI|I[ADLN]|K[SY]|LA|M[ADEINOST]|N[CDEHJMVY]|O[HKR]|PA|RI|S[CD]|T[NX]|UT|V[AT]|W[AIVY]) ?)|( USA)|((?P<region2>(A[KLRZ]|C[AOT]|D[CE]|FL|GA|HI|I[ADLN]|K[SY]|LA|M[ADEINOST]|N[CDEHJMVY]|O[HKR]|PA|RI|S[CD]|T[NX]|UT|V[AT]|W[AIVY]))USA?)|US)$/m
str = 'WMSUPERCENTER#582 PORT ORANGE FL'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end