# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\([a-zA-Z]+\)\n(.+)"
test_str = ("17.\n"
"If you go on increasing the stretching force on a wire in a\n"
"guitar, its frequency.\n"
"(a)\n"
"increases\n"
"(b)\n"
"decreases\n"
"(c)\n"
"remains unchanged\n"
"(d)\n"
"None of these\n\n"
"some random text between questions\n"
"18.\n"
"A vibrating body\n"
"(a)\n"
"will always produce sound\n"
"(b)\n"
"may or may not produce sound if the amplitude of\n"
"vibration is low\n"
"(c)\n"
"will produce sound which depends upon frequency\n"
"(d)\n"
"None of these\n"
"19.\n"
"The wavelength of infrasonics in air is of the order of\n"
"(a)\n"
"100 m\n"
"(b)\n"
"101 m\n"
"(c)\n"
"10–1 m\n"
"(d)\n"
"10–2 m")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.