$re = '/^[a-zA-Z0-9\.\,\:\;\/\s]+$/m';
$str = 'd/m/Y H:i:s
h:i:s A
l, dS F Y
d/m/Y';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);