re = /^[^0]{1}|..+/m
str = '+iCMEBY0ZQtWbnU2RPX/MmqrDPuVJzSGGWhkFd+9/zpMbHVoOlZFuF9ND1xAxsQy3YFCPIsUBEgg2RJNkPefrmQ==
0+iCMEBY0ZQtWbnU2RPX/MmqrDPuVJzSGGWhkFd+9/zpMbHVoOlZFuF9ND1xAxsQy3YFCPIsUBEgg2RJNkPefrmQ==
0
f
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end