$re = '/("[^"]*")|:/m';
$str = 'x:123; y:"z:456"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);