$re = '/(?<=Hi\s)(\S+)/m';
$str = 'Hi Gokul I don’t know much about Regular expression. Can you tell me in a detailed way?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);