$re = '/,(?![^()]*\))/m';
$str = 'aa,bb,(cc,dd),m(ee,ff)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);