$re = '/(\d+)x(\w+)\s*,\s*(\d+)x(\w+)/m';
$str = '1xAAAA,2xBBBB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);