package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d+)x(\w+)\s*,\s*(\d+)x(\w+)`)
var str = `1xAAAA,2xBBBB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}