using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\n)(\d+)\.(\d+)\.((\d+)\.)*";
string input = @"1.2.
3.4.5.
5.6.7.10";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}