$re = '/^\d+-\d+-\d+\s+\d+:\d+:\d+\s\d+\.\d+\.\d+\.\d+\s\w+\s([6-7])/m';
$str = '2019-11-09 12:05:59 10.10.10.10 my_host 0 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 1 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 2 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 3 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 4 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 5 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 6 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf
2019-11-09 12:05:59 10.10.10.10 my_host 7 message yf uif ouyf ouyf ouyf opiyf uo pgu pyi yf yif i piyf puig piuf piuf pu pif piuf piyf ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);