$re = '/{\d+}|\S.*?(?=\s*(?:{\d+}|$))/m';
$str = 'This {0} is an example {1} with a placeholder ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);