$re = '/(\[/])|\[[^]]+\]/m';
$str = 'this is [/.] a string [ra] with [/] something';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);