import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z0-9].[a-zA-Z0-9\\._%\\+\\-]{0,63}@[a-zA-Z0-9\\.\\-]+\\.[a-zA-Z]{2,30}$";
final String string = "#Good addresses\n"
+ "alain-louis.tomasian@kaptus.fr\n"
+ "101.alain-louis.tomasian@kaptus.fr\n"
+ "contact@pterodactylus.kaptus.fr\n"
+ "alain.tomasian%directeur@kaptus.fr\n"
+ "jean-bernard.Delacombe@kaptus.fr\n"
+ "jean-bernard.Delacombe@mail.pterodactylus.kaptus.fr\n"
+ "alain-louis.tomasian.alain-louis.tomasian.alain-louis.tomasian.al@kaptus.FranceMetropolitaine\n"
+ "01234567890123456789012345678901234567890123456789012345678901234@kaptus.FranceMetropolitaine\n"
+ "#Bad addresses\n"
+ "alain.tomasian+Direction-Générale@kaptus.fr\n"
+ "-alain-louis.tomasian@kaptus.fr\n"
+ "+alain-louis.tomasian@kaptus.fr\n"
+ "%101.alain-louis.tomasian@kaptus.fr\n"
+ "alain-louis.tomasian@triceratops_ssl.kaptus.fr\n"
+ "alain-louis.tomasian@kaptus.france-metropolitaine\n"
+ "alain-louis.tomasian@kaptus.XN--VERMGENSBERATUNG-PWB\n"
+ "012345678901234567890123456789012345678901234567890123456789012345@kaptus.FranceMetropolitaine\n"
+ "contact@kaptus.FranceMetropolitaineFranceMetropolitaine\n"
+ "contact@alain@kaptus.fr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}