$re = '/\s(\d{2}\:\d{2}\s(?:AM|PM|am|pm))/';
$str = 'Time today is 10:30 pm
Time today is 10:30 PM
Time today is 10:30 AM
Time today is 10:30 am
Time today is noon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);