$re = '/^(?=\d{6})(\d)\1*(?!\1)\d+$/m';
$str = '222222
122222
1111125';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);