re = /(?<!\S)\{\{[^{}]*\}\}(?:-\{\{[^{}]*\}\}){2}(?!\S)/m
str = '{{}}-{{}}-{{}}
-{{}}-{{}}-{{}}
abcd{{}}-{{}}-{{}}abcd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end