#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m):([0-9]{2}[A-Z])(?:::|:)((.*)\/\/(.*)(?:\/)(.*)?|(.*)\/\/(.*)|((ISIN) ([A-Z]{2}[0-9]{10}))?((?:[\s\S](?!:[0-9]{2}[A-Z]:))*))"
Local $sString = "{1:F01FNZWGB2SB0100803124654}{2:O5350219180911CRESCHZZE80A61337108691809110119N}{3:{108:12195636003}}{4:" & @CRLF & _
":16R:GENL" & @CRLF & _
":28E:00001/ONLY" & @CRLF & _
":20C::SEME//MONY31109D098518" & @CRLF & _
":23G:NEWM" & @CRLF & _
":98A::PREP//20180911" & @CRLF & _
":98A::STAT//20180910" & @CRLF & _
":22F::SFRE//DAIL" & @CRLF & _
":22F::CODE//COMP" & @CRLF & _
":22F::STTY//CUST" & @CRLF & _
":22F::STBA//SETT" & @CRLF & _
":97A::SAFE//0835-2393193-05-000" & @CRLF & _
":17B::ACTI//Y" & @CRLF & _
":17B::CONS//N" & @CRLF & _
":16S:GENL" & @CRLF & _
":16R:SUBSAFE" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0016431741" & @CRLF & _
"ANTEILE -I DY- PICTET CH - CHF" & @CRLF & _
"BONDS TRACKER" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF1056,8" & @CRLF & _
":93B::AGGR//UNIT/0,184" & @CRLF & _
":93B::AVAI//UNIT/0,184" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,184" & @CRLF & _
":94F::SAFE//CUST/MGTCBEBEFND" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF194,45" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0117044708" & @CRLF & _
"ANTEILE -DT USD- SWISSCANTO (CH)" & @CRLF & _
"INDEX FUND V - SWISSCANTO (CH)" & @CRLF & _
"INDEX EQUITY FUND USA" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//USD" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/USD238,6195" & @CRLF & _
":93B::AGGR//UNIT/1,044" & @CRLF & _
":93B::AVAI//UNIT/1,044" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/1,044" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF242,31" & @CRLF & _
":92B::EXCH//USD/CHF/0,97265" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0185709083" & @CRLF & _
"ANTEILE -QA- CREDIT SUISSE INDEX" & @CRLF & _
"FUND (CH) UMBRELLA - CSIF (CH)" & @CRLF & _
"EQUITY EMERGING MARKETS BLUE" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF1169,79" & @CRLF & _
":93B::AGGR//UNIT/0,201" & @CRLF & _
":93B::AVAI//UNIT/0,201" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,201" & @CRLF & _
":94B::SAFE//SHHE/9904" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF235,13" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0190222403" & @CRLF & _
"ANTEILE -QA- CREDIT SUISSE INDEX" & @CRLF & _
"FUND (CH) I UMBRELLA - CSIF (CH)" & @CRLF & _
"I EQUITY EUROPE EX CH" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/EUR1129,18" & @CRLF & _
":93B::AGGR//UNIT/0,178" & @CRLF & _
":93B::AVAI//UNIT/0,178" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,178" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF226,85" & @CRLF & _
":92B::EXCH//EUR/CHF/1,128663095" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0190227683" & @CRLF & _
"ANTEILE -QA- CREDIT SUISSE INDEX" & @CRLF & _
"FUND (CH) UMBRELLA - CSIF (CH)" & @CRLF & _
"EQUITY JAPAN" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//JPY" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/JPY231558," & @CRLF & _
":93B::AGGR//UNIT/0,117" & @CRLF & _
":93B::AVAI//UNIT/0,117" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,117" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF237,15" & @CRLF & _
":92B::EXCH//JPY/CHF/0,0087535442107" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0220919085" & @CRLF & _
"ANTEILE -FBH CHF- CREDIT SUISSE" & @CRLF & _
"INDEX FUND (CH) II UMBRELLA -" & @CRLF & _
"CSIF (CH) II GOLD BLUE" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF870,46" & @CRLF & _
":93B::AGGR//UNIT/0,047" & @CRLF & _
":93B::AVAI//UNIT/0,047" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,047" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF40,91" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0259132303" & @CRLF & _
"ANTEILE -QAH- CREDIT SUISSE" & @CRLF & _
"INDEX FUND (CH) UMBRELLA - CSIF" & @CRLF & _
" (CH) BOND GOVERNMENT EMERGING" & @CRLF & _
"MARKETS USD BLUE" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF871,8" & @CRLF & _
":93B::AGGR//UNIT/0,208" & @CRLF & _
":93B::AVAI//UNIT/0,208" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,208" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF181,33" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0304170571" & @CRLF & _
"ANTEILE -QAH- CREDIT SUISSE" & @CRLF & _
"INDEX FUND (CH) UMBRELLA - CSIF" & @CRLF & _
" (CH) BOND GOVERNMENT USD BLUE" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF910,27" & @CRLF & _
":93B::AGGR//UNIT/0,2" & @CRLF & _
":93B::AVAI//UNIT/0,2" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,2" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF182,05" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0316599023" & @CRLF & _
"ANTEILE -QAH- CREDIT SUISSE" & @CRLF & _
"INDEX FUND (CH) UMBRELLA - CSIF" & @CRLF & _
" (CH) BOND CORPORATE EUR" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF993,13" & @CRLF & _
":93B::AGGR//UNIT/0,196" & @CRLF & _
":93B::AVAI//UNIT/0,196" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,196" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF194,65" & @CRLF & _
":16S:FIN" & @CRLF & _
":16R:FIN" & @CRLF & _
":35B:ISIN CH0342181622" & @CRLF & _
"ANTEILE -D CHF- BLACKROCK" & @CRLF & _
"INVESTMENT FUNDS SWITZERLAND -" & @CRLF & _
"ISHARES SPI (R) EQUITY INDEX" & @CRLF & _
"FUND (CH)" & @CRLF & _
":16R:FIA" & @CRLF & _
":22F::FORM//BEAR" & @CRLF & _
":11A::DENO//CHF" & @CRLF & _
":16S:FIA" & @CRLF & _
":90B::MRKT//ACTU/CHF1089,63" & @CRLF & _
":93B::AGGR//UNIT/0,217" & @CRLF & _
":93B::AVAI//UNIT/0,217" & @CRLF & _
":16R:SUBBAL" & @CRLF & _
":93B::AGGR//UNIT/0,217" & @CRLF & _
":94F::SAFE//NCSD/INSECHZZXXX" & @CRLF & _
":16S:SUBBAL" & @CRLF & _
":19A::HOLD//CHF236,45" & @CRLF & _
":16S:FIN" & @CRLF & _
":16S:SUBSAFE" & @CRLF & _
":16R:ADDINFO" & @CRLF & _
":19A::HOLP//CHF1971,28" & @CRLF & _
":19A::HOLS//CHF1971,28" & @CRLF & _
":16S:ADDINFO" & @CRLF & _
"-}{5:{MAC:00000000}{CHK:DFB75BA65E32}}{S:{SAC:}{COP:P}{SIG:<SignatureList><SwSec:Signature><SwSec:SignedInfo><Sw:Reference><Sw:DigestValue>xlO1QD8wtqFYh2Dv3XOMVXW+LFK/G4wNNP+lkEbVAec=</Sw:DigestValue></Sw:Reference></SwSec:SignedInfo><SwSec:SignatureValue>PEMF@Proc-Type: 4,MIC-ONLY" & @CRLF & _
"Content-Domain: RFC822" & @CRLF & _
"EntrustFile-Version: 2.0" & @CRLF & _
"Originator-DN: cn=finprod-uh,o=creschzz,o=swift" & @CRLF & _
"Orig-SN: 1500888122" & @CRLF & _
"MIC-Info: SHA256, RSA," & @CRLF & _
" tqIGXV4JZtOE8FfTXmrBnxtWLRCRygaup2b2Rc+Ac9XjvrjJ+k24RFvuo5YrW3ek" & @CRLF & _
" +iaYiRPiW46eRRuQO2bdC9lqvDwpluuVRXLBhNkXPmqoKG3ceQM/C2pDlwrunSDu" & @CRLF & _
" RNBU3kdCBp9HBiWh/qikrCYQ/axjIUowJA+4yJV+fb8ihvkpRPlEHod85CmYyGYm" & @CRLF & _
" jKsngF66rYeR9yFu5MN20YkxmLR0NnswZjZ/EyjALjdpPNEt+h55O5RKqv7go2VF" & @CRLF & _
" w9PQws0vz5gMwZs7S//QF322QsQsXG7+rqYqd97+mkbmxGWDsU/EHneDjFsqnSgO" & @CRLF & _
" 5CR844lPC8tZInZhflckBA==" & @CRLF & _
"</SwSec:SignatureValue><SwSec:KeyInfo><SwSec:SignDN>cn=finprod-uh,o=creschzz,o=swift</SwSec:SignDN><SwSec:CertPolicyId>1.3.21.6.2</SwSec:CertPolicyId></SwSec:KeyInfo><SwSec:Manifest><Sw:Reference><Sw:DigestRef>M</Sw:DigestRef><Sw:DigestValue>MlL+Hb1Y9ZeQqxZOnv/u8bwiQNn5hj/ItM6F7gUKDBE=</Sw:DigestValue></Sw:Reference><Sw:Reference><Sw:DigestRef>Sw.E2S</Sw:DigestRef><Sw:DigestValue>eWlk1Jvu93rzuPg9VHCu9Ro9daY42/eFqlQwjcUd8t4=</Sw:DigestValue></Sw:Reference></SwSec:Manifest></SwSec:Signature></SignatureList>}}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")