$re = '/CITY:\s*\K.*/m';
$str = '
TYPE: School
CITY: ATLANTA
CITY: LAS VEGAS
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);