import re
regex = re.compile(r"(\[(?<first>icode|quote|code)[^\]]*?\](?:[\s]*?.)*?[\s]*?\[\/(?:\k<first>)\])", flags=re.IGNORECASE)
test_str = ("[quote]Id in voluptatem [U]odit itaque[/U] ea. Qui eum [URL='http://#']fugiat[/URL] doloribus dicta nisi. [icode]Exercitationem sit error maxime aperiam quaerat hic deleniti quidem[/icode]. Totam laudantium aut quia. \"Sint ut ut vel ratione,\" Qui porro eaque enim fugit.\n"
"[/quote]\n\n"
"Quam consequatur consequatur voluptate molestiae explicabo [icode]qui consectetur[/ICODE], \"Voluptatem saepe [b]ex adipisci aut est rem[/b].\" Numquam a cupiditate non officiis sed aspernatur.\n\n"
"[quote=\"Lorem Ipsum, post: 12345, member: 123\"]Aut deleniti nihil sit. Saepe dolorem blanditiis nemo. Ab et cumque nesciunt. Quos velit vel nam porro.[/quote]\n\n"
"[spoiler=\"Name\"]Unde et eius tempore consequatur. \"Vitae est ut et,\" est numquam.\"\"[/spoiler]\n\n"
"Quo <span style=\"color: #24c4f9\"><b>suscipit</b></span> sequi id ratione \"doloribus omnis\".\n\n"
"<span style=\"font-family: 'Lucida Console'\"><span style=\"font-size: 18px\">Lorem ipsum dolor sit amet, consectetur adipiscing elit.\n"
"\"\n"
"Maecenas sed nibh ac neque semper finibus.\n"
"Saepe dolorem blanditiis nemo.\n"
"\"\n"
"</b></span>\n\n"
"[CODE=html]\n\n"
"Vivamus hendrerit augue \"volutpat\", consequat risus sed, dignissim orci.\n\n"
"Fusce sed pellentesque ipsum. Suspendisse nisi odio, gravida sed leo ut, tristique posuere felis.\n"
"[/CODE]\n\n"
"Ut tempor vestibulum viverra. Vivamus imperdiet fringilla est fermentum facilisis. Quisque nec massa sit amet augue eleifend condimentum at nec arcu.\n\n"
"[CENTER][B]Quam consequa[/B] \"tur c[I]onse[/I]quatur\". Eum molestias \"et\" doloribus et rem dolorem vero qui.[/CENTER]")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")