$re = '/(?<![^\s_])[A-Za-z0-9]+/';
$str = 'Word1 Word2 _word3 ;az -az';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);