# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<=^)|(?<=\s))(?:(?:https?|ftp)://)?((?:[^\W_]|-)[^\W_]*(?:-[^\W_]*)*(?:\.(?:[^\W_]|-)[^\W_]*(?:-[^\W_]*)*)*\.[^\W_][^\W_]*)(?::\d+)?/(?:[\w~_.:/?#\[\]@!$&'*+,;=()-]*(?:(?:%[0-9a-fA-F][0-9a-fA-F])+[\w~_.:/?#\[\]@!$&'*+,;=()-]*)*)?(?=\s|$)"
test_str = ("IP Address:\n"
"93.114.205.169\n"
"0.0.0.0\n"
"0.0.0.0\n"
"10.10.10.10\n"
"99.99.99.99\n"
"199.199.199.199\n"
"255.255.255.255\n"
"256.256.256.256\n"
"02.02.02.02\n"
"111.222.13.255\n"
"1.2.3.4\n"
"1.2.3.4.5\n"
"11.22.33.44\n"
"11.22.33.44.55\n"
"255.0.1.254\n"
"255.0.1.254\n"
"In a text 255.0.1.254 there is an IP address\n"
"In a text 10.10.10.10 there is an IP address\n"
"In a text 93.114.205.169 there is an IP address\n\n"
"Domain:\n"
"example.com\n"
"https://sub5-7.example.com/\n"
"https://sub5-7.example.com\n"
"sub.sub2.example.com\n"
"www.example.com\n"
"https://sub.example.com\n"
"http://example.com\n"
"ftp://sub.mit-example222.com\n"
"In a text www.example.com there is an domain.\n"
"In a text https://sub5-7.example.com there is an domain.\n"
"In a text www.example.com there is an domain.\n\n"
"URL\n"
"93.114.205.169:443/path\n"
"93.114.205.169/path\n"
"example.com/path\n"
"sub.example.com/path\n"
"93.114.205.169/path\n"
"https://sub5-7.example.com/\n"
"http://example.com/\n"
"example.com/\n"
"sub.example.com:443/\n"
"www.--example.com/\n"
"www.examp--le.com/\n"
"www.example.co/\n"
"www.example.c/\n"
"example.com/path\n"
"ftp://sub.mit-example222.com:8080//\n"
"ftp://sub.mit-example222.com/%12\n"
"sub.example.com/path\n"
"sub.example.com/path\n"
"sub.example.com:80/path\n"
"sub.example.com/path/path/path/p/a/q/1$%h \n"
"sub.example.com/path/path/path/p/a/q/1$%1f\n"
"sub.example.com/path/path/%aa%1f%3dpath/p/a/q/1$%1f111\n"
"https://sub.example.com/path/path\n"
"http://sub.example.com/path/path\n"
"http://something.com/#$SLJFHsdq32908432098=!~abc\n"
"In a text example.com/path there is an URL path.\n"
"In a text www.example.com/path there is an URL path.\n"
"In a text www.blog.example.com/path there is an URL path.\n"
"In a text sub.example.com/paththere is an URL path.\n"
"In a text sub.example.com/path/path/path/p/a/q/1$%h there is an URL path.\n"
"In a text sub.example.com/path/path/path/p/a/q/ there is an URL path.\n\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.