import re
regex = re.compile(r"^(?P<major>0|[1-9]\d*)\.(?P<minor>0|[1-9]\d*)\.(?P<patch>0|[1-9]\d*)(?:-(?P<prerelease>(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*)(?:\.(?:0|[1-9]\d*|\d*[a-zA-Z-][0-9a-zA-Z-]*))*))?(?:\+(?P<buildmetadata>[0-9a-zA-Z-]+(?:\.[0-9a-zA-Z-]+)*))?$", flags=re.MULTILINE)
test_str = ("Before\n"
"14.0.0-dev.1644926613.1234567\n"
"14.0.0-dev.1644926613.abcdefg\n"
"14.0.0-dev.0.abcdefg\n"
"14.0.0-dev.0.01234567\n\n"
"After\n"
"14.0.0-dev.1644926613-1234567\n"
"14.0.0-dev.1644926613-abcdefg\n"
"14.0.0-dev.0-abcdefg\n"
"14.0.0-dev.0-01234567")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")