$re = '/\[(\d+)\s+TO\s+(\d+)]/m';
$str = 'value = [41 TO 80]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);