package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)AK\d{2}[01]`)
var str = `AK010CONFIDENTIALPACKET1AK011CONFIDENTIALPACKET2AK020AK011CONFIDENTIALPACKET3AK021CONFIDENTIALPACKET4AK050 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}