$re = '/(?i)(b(ä|ae)cker(ei)?|backshop)/m';
$str = 'a bäcker b
baecker c
d baeckerei
backshop
a Bäcker b
Baecker c
d Baeckerei
Backshop
baeker
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);