using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"‘.{250,}(?=[.’])(?=[,’])(?=[?’])(?=[!’])";
string input = @"Harit ent aut ant perorrovid maxim ium fuga. Porecatur molupta tectum necaest estiandit accaborempos ex exceatis niet adigene stiosam earum quam qui doluptatis a vollaboria con net volorum fuga. Aceri id que pedis et venimus quiandit etur sae reictor re, exerum int fugitae volut qui dipsum quiae cus dolupiti odios pratiunt dolenis num et omnimus doluptaturio te parchil imolupti soluptat ut asi beatia iniasperupta dus et et et escipit atquat eaturis et adio omnis et autem is diossit endendus, optas nem quiducia quo bla nis et facescius adioremquis voluptatur sedis deribusam quo veligni hillacc aestem essinctiisit eos aut mo consed ut autectur?
‘Orepere quos alist, volorum nonem se optiorercil in et laccus moditis est que etus si bea nemperio qui sin nonse la voluptatectes aut ommolupietur siminci. pictia iunt essimusament quis doluptas dit eaturia nosam quam’s volorepedi auda intis eat. res ex eserate sendisit quiate ipid quiae nonsequae commolor maion peliquis simus audae reptatiur ads eicilitaquae od que et et inimenestius in nobiti cone mo bea quas estemqu asperum dolupta atist rest, omniass itatemperum, quundestis aperspient maio tempos pratem con nis re si optae adiatqui digni dolorrum dolupta aditas aspelestem aute volorib eaquamus res culparc hillam qui dollectum quatibu struptate eum exped eos resti to consequatur, nihiciis dolum quisti qui sitat est, ipit lictiam endent. Xerrum ilis ipsum et aut et estibus cimillaborem est, arum repro ea expeles cumquis comniat. Ibus mo tem quate sentia sumquamus.’
Si acescia ipsae quodipides dollora turest facea conest offic te lam quo cuptae. Ebitius ea autem quat event quas qui sitiusc imusamus simus unt pa dic tem quae quasperia essitatur molorroreri autem que cor amet, sed quassequid ‘quia sed quam cor sante volorenias alis parum reperi tem nam am et qui net pro dit eliquiant.
Xeritium que sinum’ a nos ent aut landucimus estrum lab im sandi optatque laceperum harions erspit, solorumetus earum quat.
Sitae pro et doluptatem harcipsunda cust, cus dolescias cusam, ommos corecto tatiosam eiciet providit, sus pelendendio. Ut voluptat.
‘Ciet est, sime et ute eiunt eaquibus, nis aut omnime cone se consequame parumquat fugiatecte pe suntem quia deri blabore etur, tem ea ipsam fugitio tem quis que voluptat quia sit ipsunt etur, omnimin uscium volupta quist, que ellabore expliatem. Ucil et a vitatur, te ipissi beat atquos eossit velit eosandicim volenihil eos et, sit doloreiur ad et fugit mi, sandamus seque venes quo maio que dolor as magnat incim renda dolor simin cum fugitius pratis rem fugiatio tem fugit quatis simi, utaquis eos rernate mperferis denita venis perspis sinctat anda perum rendaep tatibus quassitio bla que etur secepeliqui rectur, cum as utemos aut audame voluptas dolorerum nonsequid eat quis dolecea quo volupta et maximus trupien imporenihici consequi ulpa vendi toresti orepudiciis audaes pereprae nonsed molum evelestio im dolorro omnis aliqui dem vendam que mi, quid eosam fugitas qui volendam landae comnim essimod igendis voluptatur?’
Edis eniat minctem. Invent peruptatatem reriam velentum quas rendit erferum lit quuntur aut harum eos vendam et vitatiis aut idiciisi te dem inihic tem int accata que natatias eostibe aquidis etur, occuptatus volorpo ssimi, eos auditae quam et inctamus eum ipit, ventet elendam sitae. Opti cone exero de aut dolore nimusa pro dolorunt, cus quo excerum volorer cipsandi vellor accaecus, sum abor minimus aeptatis ium qui officit enimusant quunt venit mollut adio. Maio. Volorep uditestis aruptas quas quaerfe rundae nis rest, optatio. Sed qui cus magniatis volor rerrum harumenihit, quibus, aligent exceptios et, sinihic imagnis magnis porera dolorem poreiust volum volendio iduciet as ea dolorup tassunt, ommodig namenis quia verum sitat idipsum ut offici vendignam harcientem consequo blabori aeriae nulloritaque dolorepe et audaest is doluptatios eatus as es ipis et enture dolum faccae doluptiis magnatia non nem natquosseque illut aut etur mo officilla ium rero voluptatqui bereria nduntia del maio qui doluptibus.
Gia volore ni dolorib ustiatium restrunt aliate apellam eum fugitem earume ventibus sed maiores sitatem in num vere plabo. Et dolorum, ut ommolest adi ut re parum is dusci dest, occati resendempor seristio. Inti in pore natem assit aut lab ius modipienim experia seri sus eos am, volorae voles ressime nihilit volore nulpari bustium quibeatibus consequi tem. Nam, con plaut quae nem adit, nemposs imustiae por aut il etur sanda consed maximusam aute plaut omnit odi volupta spedita spidero derspel libusda voles illabora cullaborest, quat.
Ommodia aut pos dit fuga. Hicias mo inulpa debit, nobit, sunt.
Ebis dolore que nihiciunt quam, id eosapero tem nit rerro cores molupta de ex et esendam veliqui num cum rem eum qui test, sequo molorit iamusan duciis eumquam quunt, incit rectios aut quia ipsanis soluptatur? Cea veliqua epudion sectem nus mo officiatur mi, adi dis ut pellore ipic tes ventur aut alitemodipis dis praerest fugitio consequi consectem restecu ptaecus, odit, ut quatium qui tecae voloratque voluptatibus vellam";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}