$re = '/(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})/mx';
$str = 'https://regex101.com/
https://github.com/BehrRiley/Gielinor/blob/master/Quests/Scripts/!QuestTemplate.yml
https://www.google.com/search?safe=active&rlz=1C1GCEU_enUS838US838&ei=eCNLXf-BBNKEjLsPvuyW6A8&q=behr_riley&oq=behr_riley&gs_l=psy-ab.3..0i8i30.115052.119018..119179...2.0..1.582.2528.0j1j5j2j0j1......0....1..gws-wiz.......0i71j35i39j0j0i131j0i67j0i13.xSKkFkgHnU8&ved=&uact=5
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);