const regex = /^(.*?foo.*?)foo/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*?foo.*?)foo', 'gm')
const str = `foo bar bash 1 foo dash mesh 3 foo poly 3 for foo
foo tar hash 1 foo gash gesh 3 foo toly 3 vor foo
foo sar wash 1 foo rash nesh 3 foo koly 3 sor foo`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}