re = /^(http:\/\/www\.|https:\/\/www\.|http:\/\/|https:\/\/)?[a-z0-9]+([\-\.]{1}[a-z0-9]+)*\.[a-z]{2,5}(:[0-9]{1,5})?(\/.*)?$/m
str = 'test.com
www.test.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end