import re
regex = re.compile(r"(?<=Amount:\s?\$)([0-9,]+\.\d{2})|(?<=Date:\s?)(\d{2}/\d{2}/\d{4})|(?<=Invoice:\s?)(\d+)|(?<=Billing Account Name:\s?)([\w\s]+)", flags=re.MULTILINE)
test_str = ("Dear Valued AdRoll Customer,\n\n"
"Your payment for invoice #5925702 has been processed. Please see below for additional details.\n\n"
"Learn more about your billing history.\n\n"
"-- Transaction Details --\n"
"Amount: $450.42\n"
"Date: 10/15/2024\n"
"Invoice: 5925702\n"
"Billing Account Name: RRL Exhbits\n"
"Profile(s):\n"
"Reagan Library\n"
"If you have any questions, please contact support@adroll.com.\n\n"
"Download Invoice PDF\n\n"
"Log in to AdRoll\n\n"
"---\n"
"If you have any questions, don’t hesitate to contact our Support team or chat with us live.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")