#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+\/+(\d+).+?psd"
Local $sString = "!Gotovoe Anya/а шарик летит/700.psd" & @CRLF & _
"!Gotovoe Anya/С 5 до 7. Время любовников (Сурдоперевод)/4478751.psd" & @CRLF & _
"!Gotovoe Anya/#вмаскешоу/8115515.psd" & @CRLF & _
"!Gotovoe Anya/#Гуднайтшоу/3627751.psd" & @CRLF & _
"!Gotovoe Anya/#Гуднайтшоу/3627751_RU.psd" & @CRLF & _
"!Gotovoe Anya/#ЛавСтайл/3086771-lavstayl.psd" & @CRLF & _
"!Gotovoe Anya/#яздесь/4572015.psd" & @CRLF & _
"!Gotovoe Anya/#ЯЗДЕСЬ/6925565.psd" & @CRLF & _
"!Gotovoe Anya/(Не)идеальная женщина/10010315.psd" & @CRLF & _
"!Gotovoe Anya/... а шарик летит/700.psd" & @CRLF & _
"!Gotovoe Anya/@Жених/5851405.psd" & @CRLF & _
"!Gotovoe Anya/«V» значит Вендетта/2457401.psd" & @CRLF & _
"!Gotovoe Anya/«Весёлые» каникулы/1341041.psd" & @CRLF & _
"!Gotovoe Anya/«Вне игры. Пролог». Документальный фильм/4460771.psd" & @CRLF & _
"!Gotovoe Anya/«Кедр» пронзает небо/1193411.psd" & @CRLF & _
"!Gotovoe Anya/«Мерседес» уходит от погони/15380.psd" & @CRLF & _
"!Gotovoe Anya/«Посейдон» спешит на помощь/1684351.psd" & @CRLF & _
"!Gotovoe Anya/«Старый» Новый год/2454371-staryy-novyy-god.psd" & @CRLF & _
"!Gotovoe Anya/«Сто грамм» для храбрости/1363311.psd" & @CRLF & _
"!Gotovoe Anya/«Тигры» на льду/2312_RU.psd" & @CRLF & _
"!Gotovoe Anya/0 в пользу Танечки/2391.psd" & @CRLF & _
"!Gotovoe Anya/1/2930981.psd" & @CRLF & _
"!Gotovoe Anya/1+1 (Сурдоперевод)/2681801.psd" & @CRLF & _
"!Gotovoe Anya/1+1 дома 8 марта/2474581.psd" & @CRLF & _
"!Gotovoe Anya/1+1 дома 8 марта/2474581-1-1-doma-8-marta-2.psd" & @CRLF & _
"!Gotovoe Anya/1+1/2214021.psd" & @CRLF & _
"!Gotovoe Anya/2 Brothers On The 4Th Floor - караоке/10307755.psd" & @CRLF & _
"!Gotovoe Anya/2 дня/95161.psd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")