# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<\\/a>)(chapter\s+[0-9]+[^<]+)?(<\\/p>)/\1<h2>\2<\/h2>\3/gmi;t' <<< "<p class=\"calibre1\"><a id=\"p1\"></a>Chapter 370: Slamming straight on</p>
<p class=\"softbreak\"> </p>
<p class=\"calibre1\">Hearing Yan Zhaoge’s suggestion, the Jade Sea City martial practitioners here were all stunned.</p>
<p class=\"calibre1\"><a id=\"p7\"></a>Chapter 372: Yan Zhaoge’s plan</p>
<p class=\"softbreak\"> </p>
<p class=\"calibre1\">Yan Zhaoge and Ah Hu sat on Pan-Pan’s back, black water swirling about Pan-Pan’s entire body, keeping away the seawater as he shot forward at lightning speed.</p>"