#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = ""SgxEpoch":\s*(\"([^0].{31}|.[^0].{30}|.{2}[^0].{29}|.{3}[^0].{28}|.{4}[^0].{27}|.{5}[^0].{26}|.{6}[^0].{25}|.{7}[^0].{24}|.{8}[^0].{23}|.{9}[^0].{22}|.{10}[^0].{21}|.{11}[^0].{20}|.{12}[^0].{19}|.{13}[^0].{18}|.{14}[^0].{17}|.{15}[^0].{16}|.{16}[^0].{15}|.{17}[^0].{14}|.{18}[^0].{13}|.{19}[^0].{12}|.{20}[^0].{11}|.{21}[^0].{10}|.{22}[^0].{9}|.{23}[^0].{8}|.{24}[^0].{7}|.{25}[^0].{6}|.{26}[^0].{5}|.{27}[^0].{4}|.{28}[^0].{3}|.{29}[^0].{2}|.{30}[^0].|.{31}[^0])\"|"")"
Local $sString = ""SgxEpoch": "00000000000000000000000000000000"" & @CRLF & _
""SgxEpoch": "00000000000000000000000000001000"" & @CRLF & _
""SgxEpoch": "00000000000000000000000000000000"" & @CRLF & _
""SgxEpoch": """ & @CRLF & _
""J8G9SQFG374OI2K4NKRPADZBERUFSZBU"" & @CRLF & _
"[]$ for i in {1..30}; do echo "\"SgxEpoch\": \"$(cat /dev/urandom | tr -dc 'A-Z0-9' | fold -w 32 | head -n 1)\""; done;" & @CRLF & _
""SgxEpoch": "RG1RLP2EVNB8HDNWH9GV4TJDB531WLXB"" & @CRLF & _
""SgxEpoch": "GVHUIQCS92Y4D22AV7MVWD3T4PNSG1CA"" & @CRLF & _
""SgxEpoch": "6XNYUHV542BZ641G7NR5J3TGIZ14805T"" & @CRLF & _
""SgxEpoch": "WJAFO7E45QR0QVHAS9OII5LSZ2BJRRDT"" & @CRLF & _
""SgxEpoch": "QSXAOKMVGZ3UT7R6K9II8W42SIKJB4CH"" & @CRLF & _
""SgxEpoch": "C7HC5SMK85CSZ45OXW29D6JAHT4ZA2H7"" & @CRLF & _
""SgxEpoch": "XRV62S6YQ5BM25NKK8VGIL31GRO4KAQC"" & @CRLF & _
""SgxEpoch": "2ZPD3Y2U4RS5YQFKK36F6BJDTOCFK1PL"" & @CRLF & _
""SgxEpoch": "I7UONV2YA6H2S245KPPQAASG801BB23A"" & @CRLF & _
""SgxEpoch": "X7OXH645EYWTISMTT5P9X46PUOMA2EFW"" & @CRLF & _
""SgxEpoch": "LF2ASFTRLY1Y1NQIO89G6GS3VHM7Y2YX"" & @CRLF & _
""SgxEpoch": "KH0KU5213C3ET7QR99K1D1TX8N6K8JG9"" & @CRLF & _
""SgxEpoch": "FOXZ8F490134F1Q9ARW5JAH50KXVC1ST"" & @CRLF & _
""SgxEpoch": "BSFDYP5T9SUNAK097LEJH2JFAH1BVO10"" & @CRLF & _
""SgxEpoch": "13IR5STLX3XIRA7D0XDSGWSTUPKBIUF4"" & @CRLF & _
""SgxEpoch": "BTQULR3SH5C5I6I6JNVDG5OPCWZYIO21"" & @CRLF & _
""SgxEpoch": "DBG0DK9R9S817XWJQU76ZS1C4NB9MH0D"" & @CRLF & _
""SgxEpoch": "6KOJH14I94WGP7WIWSXSPIG0EMEZGN7B"" & @CRLF & _
""SgxEpoch": "9A9XJEOQ157KMPQPXNZKUOZJBN9N1X82"" & @CRLF & _
""SgxEpoch": "SQXDD61TZX0PZZI40A83B0F0WYAKJ4ED"" & @CRLF & _
""SgxEpoch": "7XQ1DLU186KZ66ZTU393T0IT301UBHVY"" & @CRLF & _
""SgxEpoch": "4M0M5Y5MOMG2RPC5153JXUY14B31O19P"" & @CRLF & _
""SgxEpoch": "JY1HPMZYSCGGBUG0FG5TH8R4EXSE57EZ"" & @CRLF & _
""SgxEpoch": "74O8E3WPY26ASOHM7E91KNV84AZ8ZNTM"" & @CRLF & _
""SgxEpoch": "EOYJPEBTDDFI3T2YDFT16PZLJLOAQ0NK"" & @CRLF & _
""SgxEpoch": "0BVQ6GQF3Q12SCW4GGDMCQQXBCDRBL9Z"" & @CRLF & _
""SgxEpoch": "1L91SIZYM7ANWJE1TZX7U64QEMW267U1"" & @CRLF & _
""SgxEpoch": "E0CUT3MIJLZECDP9VE63IO4TDVPNOBJ2"" & @CRLF & _
""SgxEpoch": "KJYF7SZUSBGZDAIT5366YVQ63ECEMGQ1"" & @CRLF & _
""SgxEpoch": "P4SV9WTRL0HGOEAD48K3E1ZHP1ZTRDKN"" & @CRLF & _
"[]$" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")