$re = '/^([\w\.\-]+)@([\w\-]+)((\.(\w){2,3})+)$/m';
$str = 'test_email@google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);