$re = '/(\d)\1/m';
$str = '66046
73947
67456
67217
66861
67658';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);