import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\S+\\h+(?!0*(?:(\\d+)\\.?0*\\h+0*\\1\\.?0*|(\\d+\\.\\d*[1-9])0*\\h+\\g{2}0*)$)";
final String string = "A 1.20 1.2\n"
+ "B 1.2 1.20\n"
+ "C 01 1\n"
+ "D 1 01\n"
+ "E 1.0 1\n"
+ "F 1 1.0\n"
+ "G 2.10 3.2\n"
+ "H 4.1 3.20\n"
+ "I 04 3\n"
+ "J 4 03\n"
+ "K 4.0 3\n"
+ "L 4 3.0\n"
+ "Y 1.0 1.01\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}