// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?<foo>[abc])\k<foo>").unwrap();
let string = "12%
ab
adda
abcc
abccc
ab abc
abceec
abccccc
abcccccc
abcceeccbac
abcd abc abcde
abcbcbcbcbcbc
abc
- _ { } @
3%";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}