package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^_]+)_([^\.]+)\.(.+)`)
var str = `wooden_ball.properties
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}