re = /(19|20|21)\d{2}(0[1-9]|1[012])(0[1-9]|[12][0-9]|3[01])([01][0-9]|2[0-3])([0-5][0-9])/m
str = 'DOL$N_M1_201708100900_201712281814.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end