using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/allinstation\.com\/([A-Za-z]+(-[A-Za-z]+)+)\/([A-Za-z]+(-[A-Za-z]+)+)\.html";
string substitution = @"https://allinstation.com/$3";
string input = @"<li><span style=""font-weight: 400;"">Chắc hẳn anh em đã không còn xa lạ với cái tên “quyền lực” này nữa. Allinstation cũng có một bài viết chi tiết về Cz cũng như tầm nhìn của ông, anh em theo dõi tại </span><a href=""https://allinstation.com/allin-wiki/theo-dau-chan-quy/quy-dau-tu-three-arrows-capital-la-gi-toan-bo-thong-tin-ve-three-arrows-capital.html""><span style=""font-weight: 400;"">https://allinstation.com/nguoi-noi-tieng/ty-phu-cz-hanh-trinh-tu-dua-tre-di-cu-den-ti-phu-giau-nhat-khong-gian-crypto.html</span></a></li>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}