re = /\b(AND|OR|NOT) ((?!AND|OR|NOT)\b\w+(?: (?!AND|OR|NOT)\w+)*)/m
str = 'lorem AND ipsum dolor OR fizz NOT buzz'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end