using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^<p )?([A-z]+)(=\x22)([A-z]+)(\x22)";
string input = @"<p attributeA=""foo"" attributeB=""bar"" attributeC=""baz"" attributeD=""qux""></p>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}