#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^---((?:\R(?!---$).*)*)\R---$"
Local $sString = "" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"key: value" & @CRLF & _
"foo: bar, zip, grump" & @CRLF & _
"/*" & @CRLF & _
"Anything can go in here, once I have this section pulled out, the yaml schema" & @CRLF & _
"can do the reset. All that's important to note is that this section must be" & @CRLF & _
"terminated explicitly with a subsequent /^---\s*$/ in order to be deemed valid." & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"Anything else can follow here, more accidental frontmatter blobs can exist," & @CRLF & _
"but it should not matter since the other requirement is that the regex engine" & @CRLF & _
"will cease processing beyond the termination of the first match." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
" " & @CRLF & _
"" & @CRLF & _
"---" & @CRLF & _
"key: value" & @CRLF & _
"foo: bar, zip, grump" & @CRLF & _
"/*" & @CRLF & _
"Anything can go in here, once I have this section pulled out, the yaml schema" & @CRLF & _
"can do the reset. All that's important to note is that this section must be" & @CRLF & _
"terminated explicitly with a subsequent /^---\s*$/ in order to be deemed valid." & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"Anything else can follow here, more accidental frontmatter blobs can exist," & @CRLF & _
"but it should not matter since the other requirement is that the regex engine" & @CRLF & _
"will cease processing beyond the termination of the first match."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")