import re
regex = re.compile(r"(postgresql|postgres):\/\/([^:@\s]*(?::[^@\s]*)?@)?(?<server>[^\/\?\s]+)\b")
test_str = ("postgresql://localhost\n"
"postgresql://localhost:5433\n"
"postgresql://localhost/mydb\n"
"postgresql://user@localhost\n"
"postgresql://user:secret@localhost\n"
"postgresql://other@localhost/otherdb?connect_timeout=10&application_name=myapp\n"
"postgresql://host1:123,host2:456/somedb?application_name=myapp\n"
"postgres://myuser:mypassword@192.168.0.100:5432/mydatabase\n"
"postgresql://192.168.0.100/mydb\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")