$re = '/(?<= -).+?(?= )/m';
$str = '-w1 -w2 -w3 -w4 -w5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);