$re = '/^\d{3}-\d{3}-\d{4}$/m';
$str = '111-111-1111
555-555-5555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);