using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?<=(?:import|export)[^`'""]*from\s+[`'""])(?<path1>[^`'""]+)(?=(?:'|""|`)))|(?:\b(?:import|export)(?:\s+|\s*\(\s*)[`'""](?<path2>[^`'""]+)[`'""])";
string input = @"import { defaultTemplateProcessor } from './lib/default-template-processor.js';
import { SVGTemplateResult, TemplateResult } from './lib/template-result.js';
export { DefaultTemplateProcessor, defaultTemplateProcessor } from './lib/default-template-processor.js';
export { directive, isDirective } from './lib/directive.js';
export { removeNodes, reparentNodes } from './lib/dom.js';
export { noChange, nothing } from './lib/part.js';
export { AttributeCommitter, AttributePart, BooleanAttributePart, EventPart, isIterable, isPrimitive, NodePart, PropertyCommitter, PropertyPart } from './lib/parts.js';
export { parts, render } from './lib/render.js';
export { templateCaches, templateFactory } from './lib/template-factory.js';
export { TemplateInstance } from './lib/template-instance.js';
export { SVGTemplateResult, TemplateResult } from './lib/template-result.js';
export { createMarker, isTemplatePartActive, Template } from './lib/template.js';
import { render } from 'lit-html/lib/shady-render.js';
import { UpdatingElement } from './lib/updating-element.js';
export * from './lib/updating-element.js';
export * from './lib/decorators.js';
export { html, svg, TemplateResult, SVGTemplateResult } from 'lit-html/lit-html.js';
import { supportsAdoptingStyleSheets } from './lib/css-tag.js';
export * from './lib/css-tag.js';
import { LitElement } from 'lit-element';
import { IronMeta } from '@polymer/iron-meta/iron-meta.js';
import { whenOnline } from 'hadron-core/lib/utils/async.js';
import { apiUrl, apiVersion } from '../../src/config.js';
import { importModule, dynamicImportAvailable } from '../../src/dynamic-imports-polyfill.js';
import observeProperties from 'hadron-core/lib/utils/object-property-observer.js';
export { version };
import { ElementMixin, version } from './lib/mixins/element-mixin.js';
export { html } from './lib/utils/html-tag.js';
class Foo {
constructor() {
import(`foo.js`);
import(`${foo}`);
import('bar.js');
}
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}