re = /^(?=[a-z0-9!@#$%^&*()+=?]*[A-Z])(?=[A-Z0-9!@#$%^&*()+=?]*[a-z])[A-Za-z0-9!@#$%^&*()+=?]*$/m
str = 'aB123!
a123!
123A!
Ab123{
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end